Android2.2以下のテキスト改行処理がどうにもならなくてAndroidのバージョン判定してみた

Android2.2以下のテキスト改行処理がなかなかむかつくかんじで、Android2.3以降と条件をかえるためにjavascriptでバージョン判定とあいなる。

参考にしたのは「[javascript] アンドロイドのバージョン判別方法
というか、まんま採用させて頂きました...


function lowerAndroid(n) {
var bo = false;
var ua = navigator.userAgent.toLowerCase();
var version = ua.substr(ua.indexOf('android')+8, 3);
if(ua.indexOf("android")) if(parseFloat(version) < n) bo = true;
return bo;
}

で、例えば


if(lowerAndroid(2.3)){
処理内容
}

とすれば、2.2以下への別処理を書ける。

以上。

Javascript/jQuery | | トラックバック(0) |
Share |

トラックバック(0)

トラックバックURL: http://www.spiral-records.com/mt/mt-tb.cgi/1327

Facebookコメントプラグイン

Powered by Movable Type 4.261

Tumblr : log long long time ago